using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p(?: [^>]+)?>((?:(?!<\/?p[ >]).)*)<\/p>";
string substitution = @"$1";
string input = @"<p style=""text-align: right;"">
<p style=""text-align: center;"">
<p style=""text-align: left;"">
<p style=""text-align:center;"">
leave this content
</p>
</p>
</p>
</p>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}