import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p(?: [^>]+)?>((?:(?!<\\/?p[ >]).)*)<\\/p>";
final String string = "<p style=\"text-align: right;\">\n"
+ " <p style=\"text-align: center;\">\n"
+ " <p style=\"text-align: left;\">\n"
+ " <p style=\"text-align:center;\">\n"
+ " leave this content\n"
+ " </p>\n"
+ " </p>\n"
+ " </p>\n"
+ "</p>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}