$re = '/<p(?: [^>]+)?>((?:(?!<\/?p[ >]).)*)<\/p>/ism';
$str = '<p style="text-align: right;">
<p style="text-align: center;">
<p style="text-align: left;">
<p style="text-align:center;">
leave this content
</p>
</p>
</p>
</p>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;