# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a(.*?)href="\\/(.*?)"(.*?)>(.*)<\\/a>/<a$1href="#$2"$3>$4/img;t' <<< "<a 454545 href=\"/http://index.hu\" 45454>wha</a> dfdfdf <a class=\"df\" href=\"/com\" data-fya=\"cica\">w2</a> sdfd <a class=\"df\" href=\"/com\" data-fya=\"cica\">w2</a>"