using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a(.*?)href=""\/(.*?)""(.*?)>(.*)<\/a>";
string substitution = @"<a$1href=""#$2""$3>$4";
string input = @"<a 454545 href=""/http://index.hu"" 45454>wha</a> dfdfdf <a class=""df"" href=""/com"" data-fya=""cica"">w2</a> sdfd <a class=""df"" href=""/com"" data-fya=""cica"">w2</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}