use strict;
my $str = '<a 454545 href="/http://index.hu" 45454>wha</a> dfdfdf <a class="df" href="/com" data-fya="cica">w2</a> sdfd <a class="df" href="/com" data-fya="cica">w2</a>';
my $regex = qr/<a(.*?)href="\/(.*?)"(.*?)>(.*)<\/a>/imp;
my $subst = '<a$1href="#$2"$3>$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";