// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)<a(.*?)href="\/(.*?)"(.*?)>(.*)<\/a>"#).unwrap();
let string = "<a 454545 href=\"/http://index.hu\" 45454>wha</a> dfdfdf <a class=\"df\" href=\"/com\" data-fya=\"cica\">w2</a> sdfd <a class=\"df\" href=\"/com\" data-fya=\"cica\">w2</a>";
let substitution = "<a$1href=\"#$2\"$3>$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}