package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)<a(.*?)href="\/(.*?)"(.*?)>(.*)<\/a>`)
var str = `<a 454545 href="/http://index.hu" 45454>wha</a> dfdfdf <a class="df" href="/com" data-fya="cica">w2</a> sdfd <a class="df" href="/com" data-fya="cica">w2</a>`
var substitution = "<a$1href="#$2"$3>$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}