#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)<a(.*?)href="\/(.*?)"(.*?)>(.*)<\/a>"
Local $sString = "<a 454545 href="/http://index.hu" 45454>wha</a> dfdfdf <a class="df" href="/com" data-fya="cica">w2</a> sdfd <a class="df" href="/com" data-fya="cica">w2</a>"
Local $sSubst = "<a$1href="#$2"$3>$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)