const regex = /<a(.*?)href="\/(.*?)"(.*?)>(.*)<\/a>/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a(.*?)href="\\\/(.*?)"(.*?)>(.*)<\\\/a>', 'img')
const str = `<a 454545 href="/http://index.hu" 45454>wha</a> dfdfdf <a class="df" href="/com" data-fya="cica">w2</a> sdfd <a class="df" href="/com" data-fya="cica">w2</a>`;
const subst = `<a$1href="#$2"$3>$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);