using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""'])((?:\\\1|(?:(?!\1)).)*)(\1)";
string input = @"The sentence is 'He said ""Hello there""'
The sentence is 'He said \'Goodbye\''
The sentence is 'Let\'s go!'
The sentence is ""He said 'Hello there'""
The sentence is ""He said \""Goodbye\""
The sentence is ""Let's go!""
The sentence is ""Double quote: \""
The sentence is ""It's double quote: \""
Uncorrect line:
The sentence is 'Let's go!'
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}