$re = '/(["\'])((?:\\\\\1|(?:(?!\1)).)*)(\1)/';
$str = 'The sentence is \'He said "Hello there"\'
The sentence is \'He said \\\'Goodbye\\\'\'
The sentence is \'Let\\\'s go!\'
The sentence is "He said \'Hello there\'"
The sentence is "He said \\"Goodbye\\""
The sentence is "Let\'s go!"
The sentence is "Double quote: \\""
The sentence is "It\'s double quote: \\""
Uncorrect line:
The sentence is \'Let\'s go!\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);