re = /(["'])((?:\\\1|(?:(?!\1)).)*)(\1)/
str = 'The sentence is \'He said "Hello there"\'
The sentence is \'He said \\\'Goodbye\\\'\'
The sentence is \'Let\\\'s go!\'
The sentence is "He said \'Hello there\'"
The sentence is "He said \\"Goodbye\\""
The sentence is "Let\'s go!"
The sentence is "Double quote: \\""
The sentence is "It\'s double quote: \\""
Uncorrect line:
The sentence is \'Let\'s go!\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end