use strict;
my $str = 'The sentence is \'He said "Hello there"\'
The sentence is \'He said \\\'Goodbye\\\'\'
The sentence is \'Let\\\'s go!\'
The sentence is "He said \'Hello there\'"
The sentence is "He said \\"Goodbye\\""
The sentence is "Let\'s go!"
The sentence is "Double quote: \\""
The sentence is "It\'s double quote: \\""
Uncorrect line:
The sentence is \'Let\'s go!\'
';
my $regex = qr/(["'])((?:\\\1|(?:(?!\1)).)*)(\1)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}