import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"'])((?:\\\\\\1|(?:(?!\\1)).)*)(\\1)";
final String string = "The sentence is 'He said \"Hello there\"'\n"
+ "The sentence is 'He said \\'Goodbye\\''\n"
+ "The sentence is 'Let\\'s go!'\n\n"
+ "The sentence is \"He said 'Hello there'\"\n"
+ "The sentence is \"He said \\\"Goodbye\\\"\"\n"
+ "The sentence is \"Let's go!\"\n\n"
+ "The sentence is \"Double quote: \\\"\"\n"
+ "The sentence is \"It's double quote: \\\"\"\n\n"
+ "Uncorrect line:\n"
+ "The sentence is 'Let's go!'\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}