# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(\*(?:(?!\(\*|\*\)).)*\*\)(*SKIP)(*F)|\(\*/</gm;t' <<< "Some text (* Invalid Macro Insert some text (*ValidMacroInsert*)
Some text Invalid Macro Insert *) some text (*ValidMacroInsert*)"