const regex = /\(\*(?:(?!\(\*|\*\)).)*\*\)(*SKIP)(*F)|\(\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\*(?:(?!\\(\\*|\\*\\)).)*\\*\\)(*SKIP)(*F)|\\(\\*', 'gm')
const str = `Some text (* Invalid Macro Insert some text (*ValidMacroInsert*)
Some text Invalid Macro Insert *) some text (*ValidMacroInsert*)`;
const subst = `<`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);