import Foundation
let pattern = #"\(\*(?:(?!\(\*|\*\)).)*\*\)(*SKIP)(*F)|\(\*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Some text (* Invalid Macro Insert some text (*ValidMacroInsert*)
Some text Invalid Macro Insert *) some text (*ValidMacroInsert*)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)