use strict;
my $str = 'Some text (* Invalid Macro Insert some text (*ValidMacroInsert*)
Some text Invalid Macro Insert *) some text (*ValidMacroInsert*)';
my $regex = qr/\(\*(?:(?!\(\*|\*\)).)*\*\)(*SKIP)(*F)|\(\*/mp;
my $subst = '<';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";