$re = '/\(\*(?:(?!\(\*|\*\)).)*\*\)(*SKIP)(*F)|\(\*/m';
$str = 'Some text (* Invalid Macro Insert some text (*ValidMacroInsert*)
Some text Invalid Macro Insert *) some text (*ValidMacroInsert*)';
$subst = "<";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;