re = /\(\*(?:(?!\(\*|\*\)).)*\*\)(*SKIP)(*F)|\(\*/m
str = 'Some text (* Invalid Macro Insert some text (*ValidMacroInsert*)
Some text Invalid Macro Insert *) some text (*ValidMacroInsert*)'
subst = '<'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result