#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\(\*(?:(?!\(\*|\*\)).)*\*\)(*SKIP)(*F)|\(\*"
Local $sString = "Some text (* Invalid Macro Insert some text (*ValidMacroInsert*)" & @CRLF & _
"Some text Invalid Macro Insert *) some text (*ValidMacroInsert*)"
Local $sSubst = "<"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)