using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"bob(?!.*bob)";
string substitution = @"";
string input = @"joe,bob,luis,sancho,
bob,marco,lura,hannah,bob,marco,luis";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}