$re = '/bob(?!.*bob)/';
$str = 'joe,bob,luis,sancho,
bob,marco,lura,hannah,bob,marco,luis';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;