const regex = /bob(?!.*bob)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('bob(?!.*bob)', 'g')
const str = `joe,bob,luis,sancho,
bob,marco,lura,hannah,bob,marco,luis`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);