use strict;
my $str = 'joe,bob,luis,sancho,
bob,marco,lura,hannah,bob,marco,luis';
my $regex = qr/bob(?!.*bob)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";