re = /bob(?!.*bob)/
str = 'joe,bob,luis,sancho,
bob,marco,lura,hannah,bob,marco,luis'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result