using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Aa][Tt][Uu][0-9]{8}\D";
string input = @"ATU12345678
AT123456789
AT12345678
DE123456789
DE1234567a9
DE12345678
DE1234567899
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}