import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[Aa][Tt][Uu][0-9]{8}\\D";
final String string = "ATU12345678\n"
+ "AT123456789\n"
+ "AT12345678\n"
+ "DE123456789\n"
+ "DE1234567a9\n"
+ "DE12345678\n"
+ "DE1234567899\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}