re = /[Aa][Tt][Uu][0-9]{8}\D/
str = 'ATU12345678
AT123456789
AT12345678
DE123456789
DE1234567a9
DE12345678
DE1234567899
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end