const regex = /[Aa][Tt][Uu][0-9]{8}\D/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[Aa][Tt][Uu][0-9]{8}\\D', 'g')
const str = `ATU12345678
AT123456789
AT12345678
DE123456789
DE1234567a9
DE12345678
DE1234567899
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}