package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[Aa][Tt][Uu][0-9]{8}\D`)
var str = `ATU12345678
AT123456789
AT12345678
DE123456789
DE1234567a9
DE12345678
DE1234567899
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}