import Foundation
let pattern = #"[Aa][Tt][Uu][0-9]{8}\D"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ATU12345678
AT123456789
AT12345678
DE123456789
DE1234567a9
DE12345678
DE1234567899
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)