use strict;
my $str = 'ATU12345678
AT123456789
AT12345678
DE123456789
DE1234567a9
DE12345678
DE1234567899
';
my $regex = qr/[Aa][Tt][Uu][0-9]{8}\D/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}