using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+|[\s]+<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+)|^[\s]+";
string input = @" <?xml version=""1.0"" encoding=""utf-8""?>
<string xmlns=""http://tempuri.org/"">
<Status>{0}</Status>
<Currency>{1}</Currency>
<WalletBalance>{2}</ WalletBalance >
</string>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}