use strict;
my $str = ' <?xml version="1.0" encoding="utf-8"?>
<string xmlns=""http://tempuri.org/"">
<Status>{0}</Status>
<Currency>{1}</Currency>
<WalletBalance>{2}</ WalletBalance >
</string>';
my $regex = qr/(<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+|[\s]+<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+)|^[\s]+/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}