$re = '/(<\?xml[a-zA-Z0-9 .""\',?=-]+>[\s]+|[\s]+<\?xml[a-zA-Z0-9 .""\',?=-]+>[\s]+)|^[\s]+/';
$str = ' <?xml version="1.0" encoding="utf-8"?>
<string xmlns=""http://tempuri.org/"">
<Status>{0}</Status>
<Currency>{1}</Currency>
<WalletBalance>{2}</ WalletBalance >
</string>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);