#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img\b(?![^>]*\bnosecure\b)([^>]*)>"
Local $sString = "no hit:" & @CRLF & _
"<img nosecure="" src="how" style=""/>" & @CRLF & _
"<img src="how" nosecure="" style="" />" & @CRLF & _
"<img src="how" nosecure style="" />" & @CRLF & _
"<img src="never" style="" nosecure />" & @CRLF & _
"<img src="never" style="" nosecure/>" & @CRLF & _
"<img src="never" style=""nosecure/>" & @CRLF & _
"<img src="never" style=""nosecure />" & @CRLF & _
"" & @CRLF & _
"must find:" & @CRLF & _
"<img src="never" style=""/>" & @CRLF & _
"<img src="how" style=""/>" & @CRLF & _
"<img src="nosecure" style=""/>" & @CRLF & _
"<img src="nosecurettt" style=""/>" & @CRLF & _
"<img src="something" style=""/>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")