re = /<img\b(?![^>]*\bnosecure\b)([^>]*)>/
str = 'no hit:
<img nosecure="" src="how" style=""/>
<img src="how" nosecure="" style="" />
<img src="how" nosecure style="" />
<img src="never" style="" nosecure />
<img src="never" style="" nosecure/>
<img src="never" style=""nosecure/>
<img src="never" style=""nosecure />
must find:
<img src="never" style=""/>
<img src="how" style=""/>
<img src="nosecure" style=""/>
<img src="nosecurettt" style=""/>
<img src="something" style=""/>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end