const regex = /<img\b(?![^>]*\bnosecure\b)([^>]*)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\b(?![^>]*\\bnosecure\\b)([^>]*)>', 'g')
const str = `no hit:
<img nosecure="" src="how" style=""/>
<img src="how" nosecure="" style="" />
<img src="how" nosecure style="" />
<img src="never" style="" nosecure />
<img src="never" style="" nosecure/>
<img src="never" style=""nosecure/>
<img src="never" style=""nosecure />
must find:
<img src="never" style=""/>
<img src="how" style=""/>
<img src="nosecure" style=""/>
<img src="nosecurettt" style=""/>
<img src="something" style=""/>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}