import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\b(?![^>]*\\bnosecure\\b)([^>]*)>";
final String string = "no hit:\n"
+ "<img nosecure=\"\" src=\"how\" style=\"\"/>\n"
+ "<img src=\"how\" nosecure=\"\" style=\"\" />\n"
+ "<img src=\"how\" nosecure style=\"\" />\n"
+ "<img src=\"never\" style=\"\" nosecure />\n"
+ "<img src=\"never\" style=\"\" nosecure/>\n"
+ "<img src=\"never\" style=\"\"nosecure/>\n"
+ "<img src=\"never\" style=\"\"nosecure />\n\n"
+ "must find:\n"
+ "<img src=\"never\" style=\"\"/>\n"
+ "<img src=\"how\" style=\"\"/>\n"
+ "<img src=\"nosecure\" style=\"\"/>\n"
+ "<img src=\"nosecurettt\" style=\"\"/>\n"
+ "<img src=\"something\" style=\"\"/>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}