use strict;
my $str = 'no hit:
<img nosecure="" src="how" style=""/>
<img src="how" nosecure="" style="" />
<img src="how" nosecure style="" />
<img src="never" style="" nosecure />
<img src="never" style="" nosecure/>
<img src="never" style=""nosecure/>
<img src="never" style=""nosecure />
must find:
<img src="never" style=""/>
<img src="how" style=""/>
<img src="nosecure" style=""/>
<img src="nosecurettt" style=""/>
<img src="something" style=""/>
';
my $regex = qr/<img\b(?![^>]*\bnosecure\b)([^>]*)>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}