import re
regex = re.compile(r"<img\b(?![^>]*\bnosecure\b)([^>]*)>")
test_str = ("no hit:\n"
"<img nosecure=\"\" src=\"how\" style=\"\"/>\n"
"<img src=\"how\" nosecure=\"\" style=\"\" />\n"
"<img src=\"how\" nosecure style=\"\" />\n"
"<img src=\"never\" style=\"\" nosecure />\n"
"<img src=\"never\" style=\"\" nosecure/>\n"
"<img src=\"never\" style=\"\"nosecure/>\n"
"<img src=\"never\" style=\"\"nosecure />\n\n"
"must find:\n"
"<img src=\"never\" style=\"\"/>\n"
"<img src=\"how\" style=\"\"/>\n"
"<img src=\"nosecure\" style=\"\"/>\n"
"<img src=\"nosecurettt\" style=\"\"/>\n"
"<img src=\"something\" style=\"\"/>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")