$re = '/<img\b(?![^>]*\bnosecure\b)([^>]*)>/';
$str = 'no hit:
<img nosecure="" src="how" style=""/>
<img src="how" nosecure="" style="" />
<img src="how" nosecure style="" />
<img src="never" style="" nosecure />
<img src="never" style="" nosecure/>
<img src="never" style=""nosecure/>
<img src="never" style=""nosecure />
must find:
<img src="never" style=""/>
<img src="how" style=""/>
<img src="nosecure" style=""/>
<img src="nosecurettt" style=""/>
<img src="something" style=""/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);