#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/([a-z0-9-]+\.)*mckinsey\.com(:[0-9]+)?$"
Local $sString = "http://mckinsey.com" & @CRLF & _
"https://mckinsey.com" & @CRLF & _
"https://abc.mckinsey.com" & @CRLF & _
"https://a.b.4-0-4.mckinsey.com" & @CRLF & _
"https://badmckinsey.com" & @CRLF & _
"https://bad.com?mckinsey.com" & @CRLF & _
"https://bad.com#mckinsey.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")