import Foundation
let pattern = #"https?:\/\/([a-z0-9-]+\.)*mckinsey\.com(:[0-9]+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
http://mckinsey.com
https://mckinsey.com
https://abc.mckinsey.com
https://a.b.4-0-4.mckinsey.com
https://badmckinsey.com
https://bad.com?mckinsey.com
https://bad.com#mckinsey.com
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)