import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/([a-z0-9-]+\\.)*mckinsey\\.com(:[0-9]+)?$";
final String string = "http://mckinsey.com\n"
+ "https://mckinsey.com\n"
+ "https://abc.mckinsey.com\n"
+ "https://a.b.4-0-4.mckinsey.com\n"
+ "https://badmckinsey.com\n"
+ "https://bad.com?mckinsey.com\n"
+ "https://bad.com#mckinsey.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}