// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/\/([a-z0-9-]+\.)*mckinsey\.com(:[0-9]+)?$").unwrap();
let string = "http://mckinsey.com
https://mckinsey.com
https://abc.mckinsey.com
https://a.b.4-0-4.mckinsey.com
https://badmckinsey.com
https://bad.com?mckinsey.com
https://bad.com#mckinsey.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}