$re = '/https?:\/\/([a-z0-9-]+\.)*mckinsey\.com(:[0-9]+)?$/m';
$str = 'http://mckinsey.com
https://mckinsey.com
https://abc.mckinsey.com
https://a.b.4-0-4.mckinsey.com
https://badmckinsey.com
https://bad.com?mckinsey.com
https://bad.com#mckinsey.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);