const regex = /https?:\/\/([a-z0-9-]+\.)*mckinsey\.com(:[0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/([a-z0-9-]+\\.)*mckinsey\\.com(:[0-9]+)?$', 'gm')
const str = `http://mckinsey.com
https://mckinsey.com
https://abc.mckinsey.com
https://a.b.4-0-4.mckinsey.com
https://badmckinsey.com
https://bad.com?mckinsey.com
https://bad.com#mckinsey.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}